Ticket to world cup

Today I came to know about the new event called Ticket to world cup. As per T&C one has to send or pay money via upi on jupiter app. So I transferred 100rupees to my friend via send to contact option, but no there is no change in progress bar. Its still showing 0. Is there any other conditions should I meet?

I can see a condition saying ‘user need to claim the offer.’ Not sure what that mean!
Hope @saurabh.s can help in this regard as I can see him already completed the first milestone

Did u transfer from ur Jupiter account only?

for the transaction I have done, all mentioned conditions met. I don’t see any claim offer button. Idk how he completed it. Waiting for someone to answer…

yes, I didn’t linked any other account for upi

Not supposed to happen, anyway raise a ticket. If u don’t get any solution after that let us know.

The milestone 1 will be completed only after making two successful transaction min. of 50rs each.

I did with 100 first, and then with 60. still no change in progress bar

@Hasil I can confirm the same :+1:t2:
Done three transactions of 75, 55 and 88 today morning . The first one was done via Pay to Contact mode and other two by entering UPI id. The amount used was Jupiter balance.
But till now, its not updated on the ’ Ticket Offer’ page.
As Hasil said, there is no change in the progress bard and it is showing my progress as 0/2.
Are there any bugs or missing some terms and condition?

Here are some updates:
I submitted a support request through the chat option within the app. The support executive assured me that the problem would be resolved by September 18th 11:59 PM (Ticket ID: 2457584).

In order to verify if this issue is common to all users, I requested my brother to initiate two UPI transactions of over Rs 50 each from his Jupiter ID to my account. I expected encountering the same issue, but he successfully reached Milestone 1 and received 20 Jewels.

I also contacted with them, and they told me they passed this to this expert.

I think this problem is not there for everyone

Hello @Hasil, I’ve completed three UPI transactions today, and to my surprise, Milestone 1 and Milestone 2 are marked as finished. Additionally, I’ve earned 25 and 40 jewels for completing these milestones, respectively.
Could you please attempt three transactions today and check if the progress bar is advancing or not?

I’d like to bring up another point for consideration: why do different users have different milestone unlocking criteria (attached is my mine and my brother’s) as well as different campaign date? Is this the normal behaviour? Could you please confirm this, @saurabh.s?

I think no. of txn for completing offer milestones vary for different users. I received the offer shown in the second picture.

The why is more so associated with the user profile.

yes it worked for me on the same day u mentioned.

and idk why its not counted in milestone 6. its still 0

1 Like

Same issue here…
Milestone 6 is still showing as 0 out of 20
Edit (17/9/23): Still now, it is showing as 0 out of 20

@saurabh.s @Hasil Bros, Can you please confirm whether its the same or not for you guys now?

this error fixed for me. Everything is perfect now. Thanks for the good event Jupiter :heart:

1 Like

@Hasil Was it fixed automatically or did you have to contact chat support?
As a result, did the previous transactions start counting towards Milestone 6?

I have done 6 transactions today and I can see it is counted towards towards Milestone 6. and it is showing as 6 out of 20 !!!

1 Like

It fixed automatically and previous transactions didn’t counted towards milestone 6. I did a transaction today morning, it counted towards milestone 6.

I didn’t worry about that previous transactions not counted, because its easy win event.


Thanks for the info @Hasil :blob_thanks:
So, which means it is solved me for as well :+1:t2:
Hence, I request you to kindly close this thread my marking ‘Solution’ :cool_doge: :cool_doge:

1 Like