Not able to open the Jupiter Application

Hello community,

I am not able to open the Jupiter Application . It keeps loading forever while at the starting page. I tried updating the application, uninstalling and installing again no use, its stuck and says “verifying your mobile number”

Earlier the Application did not open it was stuck and loading in the starting opening page now after re installing it’s in the same status of verifying your mobile number. Anyone else facing the same issue ? please suggest ideas and help .



Same issue

1 Like

I’ve come here to see if it’s just me.
I had received a notice saying that they were having a debit card problem and this may be a maintenance pause. :crossed_fingers:

I had a word with the customer service executive and apparently they are working on this issue as well as the technical glitch on using the debit cards and was faced from yesterday. Hoping to get a solution at the earliest.

1 Like


Apologies for the inconvenience caused. We are experiencing a temporary hiccup with our app, and our team of experts are working to fix the issues as soon as possible!

1 Like

Thank you for your response and clarification we appreciate the same and hope the glitches are resolved at the earliest. Thanks again

@here Can someone check again? It’s stabilised now! :tick:


Heyyy thank you. I was about to update here. My account is stable and I even tried making a transaction using debit card. It works perfectly fine. Thanks to the Jupiter team for the prompt action taken.

Works gud now

same issue facing 4days
any bug???
maintenance work running
please updation working on??