External mutual fund dashboard not showing


I don’t see the external mutual fund dashboard, nor the money dashboard showing amount, i just see explore option here, but don’t see the invested amount

1 Like

Hi Akash,

Can you share your app version and device type (Android/iOS)?

Also a screenshot if possible.

1 Like

Hi ,

My app version is 2.0.18 i am on the lastest version ,i am on Android os
PFA for the issue

1 Like

Any update?

Dear @Akash1 , Have you granted all the required permissions asked by app. :eyebrow:

Yes, i was able to view this earlier but all of a sudden it was gone

1 Like

My recommendation would be to clear the app cache and data, and then check whether the issue has been resolved or not. Please try it once and see.

I think Jupiter removed that feature in an update, not sure when and how.
@Shawnpinto can you check the status of CAMS external funds dashboard.

1 Like

Interesting. I am still seeing the option to connect my email to track external mutual Funds.

@Akash1 This likely happened because you tried to generate the CAS report and then forwarded it to our email - investments@jupiter.money.

Could you use our app in-built flow, so this issue does not arise?

Let us know if this worked.

1 Like

Hi @razack I did try that but it did not work.

@Shawnpinto could you please let me know which in-built flow you are referring, I don’t see the external option itself to request. could you please guide here, as yangesh mentioned I was having that option but now I do not have it , so don’t know how to proceed.

Hey @Akash1

Head over to the investments tab and there you should see a button to go to the mutual fund dashboard. There you would see a slider to go to an external mutual fund and there you should see an option to either connect via google or manually forward the cas statement.

1 Like

Hi @Shawnpinto I browsed the ivestement tab and I can see option of explore there as well I went into that but I don’t see option of external mutual fund.

also in the investment tab, i went through all the clickable, but none are leading to external mutual fund option.

@Akash1 is it possible for you you take a video of the steps that you taking to reach these screens and send the video link to Shawn via DM. This will help the team understand and recreate the error and spot the bug.

Hi @yagnesh01 I have shared the video link to @Shawnpinto .

@Shawnpinto could you please check


I think, I kind of understood the issue here .

The explore mutual funds tab on the money page is taking you to the Jupiters mutual funds page.

However I think if you click on the investments tab in the home page and select the mutual funds explore option there, it might take you to the dashboard.

The UI might be a bit different as I am lab testing new investments tab

No its behaving the same, its take me to the same page as it is from the money tab.
I have shown in the video from investment tab as well as from the money section, its showing the same

I beleive, with the video shared with Shawn will assist the team in pin pointing the error.

1 Like

Thanks for sharing @Akash1 !
I think we found out what the issue was.

Hypothesis - Kyc for Mutual funds.
We’ll get this checked and let you know.


@Akash1 We think its because you’ve not done a SIP through Jupiter.
Could you register a SIP, then track external funds, and then cancel/pause the SIP?

This should work.