Sleep feature

The sleep feature has a bug. Ideally it is applicable between 12 and 6. Sometimes it doesn’t respond if you want to manually deactivate it better 12 am and 6 am.

This is definitely a bug

  • Date and time of the bug -13 March 6:20 am
  • Action: What did you do to produce the bug - Go to debit card → click sleep
  • Expected result: What was supposed to happen. - debit card should have been active and allowed transaction
  • Actual result: What actually happened. - debit card is still in sleep mode. Unable to wake
  • Device name and model: OnePlus 7, iPhone XR
  • Reproducibility: No. of times you were able to produce the bug. - 7
  • Connection type: Wi-Fi
  • Name of the cellular/ Wi-Fi provider: Jio
  • Screenshots/video: Keeping in mind - no personal information is shown. If it’s visible, please do hide it. - unable to take ss
  1. We will only look at the bugs reported in this format. Please do follow this template if you’re reporting a bug.
1 Like

Probably because federal bank turns off their servers at that time like clock work.
Transactions between 12:30 to 4:30 in the early hours of morning are “prohibited”. Unless it’s via debit card.

Unsleeping the card involves the servers (probably), which is why you were unable to test it out

Hi @s_maheshwaran, connecting with you over a DM for a few more details. Thank you.

@s_maheshwaran Ah it’s not a bug. It’s expected behavior.
This is how it works:

  • All the sleep enable and disable requests are put into a queue, then executed in order at 6 am and at 12 am.
  • All queued users take 40 to 50 min to effectively enable and disable sleep for the last person on the queue.
  • If anyone tries it before 6 or after 12 it’s immediate but during the queue processing time at 6 and 12 am it depends on the user’s position in the queue.

Maybe when you put it on sleep during 6 to 12 next time, just see how long it takes for it to go to sleep.

2 Likes

This calls for a Jupiter Engineering section on this forum :wink:

1 Like