Security Alert

Mpin/ fingerprint authentication bug.

Happened at least 2 times.

Steps : tap on Jupiter app to open. Fingerprint authentication screen will be shown, I chose to enter mpin as authentication, directly home screen appeared. Didn’t allowed me to enter mpin.

Device OnePlus 7T, Android 12. OS version Oxygen os 12.1 open beta 1.

App version : 1.5.44.


Uh oh. That’s not good.
@BeingIncog Are you able to replicate it repeatedly?

1 Like

Yes. Still happens.

This happens even after phone restart and clearing app data and cache.

@BeingIncog Got it. Thanks for sharing! The team is checking this out.
You’ve shared the details for this issue in advance. I’ll let you know if anything else is needed.

1 Like

@Shawnpinto any update?

@BeingIncog Yup! We’ll need your help with checking a few things. Lemme ping you.

1 Like


1 Like

Thank you!

1 Like

@BeingIncog We found out the cause.

We believe this is due to the Android 12.1 update. There was a priority change in terms of authentication.

It is taking Face authentication as the first authentication instead of biometrics. Can you try to disable the face auth? It will work as BAU (biometrics followed by Mpin).

Let me know, thanks!

1 Like

Face unlock is off because I don’t trust that unlock system and never turned on/used it. Only using fingerprint unlock and pin unlock.

So it was off before this had happened, yes?

1 Like

Yes. Also I just now disabled and re-enable the pin and fingerprint authentication.

1 Like

How is it now? Is it still the same?

1 Like

Yes, still the same. I think it’s OnePlus fault. Their amalgamation of oses has so many bugs.

Not quite. One of our team members faced something similar.
So he had an Oppo device. After the Android 12.1 update, the Jupiter app did not need any Mpin or finger print login.

I believe this is OS related. We’ll look more into this.

1 Like

I own a OnePlus device as well but the OS is on android 12.
Yet to receive the 12.1 update. Let me check this affects me too :blob_worried:

1 Like

Fingerprint authentication works. But just that use mpin doesn’t.

The other thing is mpin works when transacting through app UPI payment.

OS level issue. BugPlus. OnePlus is now worst of the worst.

Wait, this is just for OnePlus? I think is Android 12 in general :face_with_monocle: