Invalid application bug

This error is shown randomly. I tried turning off developer mode still same issue…

Edit: my internet was off, after enabling internet the bug got fixed :sweat_smile: :melting_face:
Is it the new way of asking me to turn on internet :grin:

For me, when the internet was turned off, the app did open but the message displayed stated ‘you seem to have lost connectivity’

1 Like

Try clearing cache maybe. For me the above message shows.

Same here. I also got the same error message

1 Like

Ideally, if the internet is turned off, it should show you the ‘lost in space’ error. There’s a fun picture of a spaceman floating in space in a goofy pose :face_with_hand_over_mouth:

1 Like

Same here as well

1 Like

Am facing the same bug. Have not been able to use the app after the recent update.

Tried the above solutions such as uninstalling and installing the app + clearing cache etc.

@Shawnpinto I think it’s time to look at this bug :neutral_face:

@anjannair @Aswin_Benny while the issue is being discussed here, report this to the support team. This will ensure a ticket gets assigned to the issue and the right teams are looped in.

1 Like

Done. Raise the issue by mailing the support team.


I managed to fix my issue here’s how - I have my custom DNS provider enabled on Android under Android settings called “Private DNS”. This DNS provider is responsible for blocking all trackers, ads, etc. While checking my network logs (logged by the DNS provider) I noticed it was blocking 2 URLs - optimzely[dot]com and clevertap-prod[dot]com.

When I switch off my private DNS the Jupiter app works and opens. I have relayed the same to the Jupiter team that was in touch with me.

For those facing this issue try disabling such AdBlock apps or settings to use the app till it gets fixed by the devs at Jupiter.


Oh yeah, jupiter money is filled with bad design that it can’t even detect no Internet but instead gives this warning.

Update: The modded application error appears when user is offline - this will be fixed in 2.2.2 release.


Bugs are common in all apps, but majority of them won’t fix it even if it was reported. But jupiter is fixing those bugs that are reported.

Kudos to jupiter for that :zap::zap:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.