Not able to access the app

Today i tried multiple times to open the application but not able to do so. Its only showing the jupiter splash screen, its not even showing up the pin/biometric login options. Please help/confirm is it a problem from my end or yours asap.

Mailed to support also regarding this

@Sridip_Dutta this seems to be a user specific issue. The fact that you have reported this to the support channel, means this will get tracked to closure.

Please check if there is a pending app update. If yes, please update the app. Also, if you are an android user, try clearing the app cache.

the app is upto date

Hai @Sridip_Dutta Welcome to the community.
Did you clear the app cache/ data?
I suggest you to do it and retry. and please update the status here :+1:
Also, please confirm whether other apps are working smoothly or not.

yes other apps are working, tried with clear cache still the same issue,
but should I try clear data as it will remove all the data related to the app so might need to re login again?

1 Like

Yes, You need to log in again when you go with the clear data option.
Another solution is uninstalling and re-installing the app, which too needs to enter login details.
Is there any issue with your mobile number? If not, you can proceed with that option.

no issue with phn, let me try this

tried clearing data, its still showing the same screen

Ok. Then I please request take the image ( recording is better) of the issue and share with Shawn via DM or here in community.
Also, suggest to do the same via email to

Btw, which handset are you using?

sure, using samsung f23, it was working fine till yesterday

Such issues do come up. Record a video so that the root cause of the issue can be traced and share with the support team. This will ensure your issue is tracked to closure.

yes, I recorded but the jupiter screen is showing blank(ig due to security reasons)

Kindly capture the image or record by using another device.
Since its Android, you cannot take screenshot or screen record it (such permission is restricted due to security reasons)

Yup. A video/recording can help further.
@Sridip_Dutta you can share it with on DMs. I’ll have the team look at it to figure this out for you :slight_smile:

1 Like

tried uploading the video in your DM but not able to.
I have send the video to the support mail

You can upload the recording to google drive and can send the link to Shawn :+1:
Hope that works


sent to @Shawnpinto
I tried installing in a diff samsung phone it worked, tried same in mine Samsung f23 uninstalled and re-installed the issue persists

Nothing to worry bro. Our community manager, Shawn, will look into it and will assign to the concerned team. Hopefully the issue will be resolved soon :+1: :+1:
Don’t forget to update the status here once it gets solved.

sure, though its urgent, but can’t do anything

@Sridip_Dutta Since you’ve mentioned that you’ve connected with the team through email, if there’s a ticket ID generated, you can let me know through DMs.