Finally something big came

A very big thanks to the Jupiter team, now I am able to take screenshot of Jupiter app.

Finally you guys listened.:pray:

I use Android

1 Like

Are you using iOS or Android?
If on Android, is it through 3rd party app?

Most probably iOS.

I tried taking a screenshot now in app version 2.2.6. It didn’t allow me.

Gives me this error - “Taking screenshot isn’t allowed by the app or your organisation”

@Ajieethdesign FYI, the context is that iOS had screenshot enabled even before the latest app update.

Look at his notification panel . Feels like android :thinking:.
Screenshot is restricted for me on the same page :neutral_face:

1 Like

The phone is definitely Android just looking at the notification panel.


Wow! A mystery… :smiley:

@Ajieethdesign Is your phone rooted? What is your phone make? If you don’t mind sharing…

There could be some sections of the app (non financial ones ) where screenshots could be allowed.


I went to the same page on screenshot. It is screenshot restricted


Pixel 6a

1 Like

I had the same thought and attempted to capture a screenshot of the specific page or section. :grin:
Just as @Aswin_Benny pointed out, unfortunately, it’s restricted.

@Ajieethdesign Have you tried to take screenshot of Jupiter’s homepage ? Is that working? That’s a new info. So no third party app is needed for Pixel 6a !!!


Thanks for sharing. :smiley:

Guess Google thinks we are as good as Apple in security. So we’ll allow the screenshots on Financial apps. :wink: