Email ID change on Jupiter 📧

Hey folks!

We’ve enabled the email ID change feature to some of our users and it’s live.
If you cannot see it yet, it should be visible in the coming weeks.

How to access:
Settings > Account details > Profile > under personal details > Email address (Edit button)

Note:

  • We couldn’t put this as a lab test since it’s not something we can repeatedly test (Like changing your email ID every time)
  • Important note - You can’t edit your email ID if you have a Jupiter investments account.
  • The edit option is there for everyone. If the feature is not enabled, then you see an error screen with a button to request for early access.


@trust_level_0

6 Likes

Feature updated in app.

Not excess for mail id change edit button

2 Likes

When will feature to update mobile number come??

1 Like

Awesome, I hope address change is not very far, along with separation of communication and permanent address.

1 Like

who to change linked mobaile nomber

I do see the edit option, but it says ‘Coming Soon’.

1 Like

@Zed Looks like you don’t have the email change feature yet.
You will see a request access button for early access.

Oh and, we are trying to roll this out to all users by end of this week. (TBD)

1 Like

Thats fine, I received a call from support a few days ago, they requested me to wait till 14th of November to change the mail address. She said changes can be made after 90 days.

:bell: Update for Email ID change on Jupiter :bell:
Email change is now live for all users :tada:

Eligibility Checks for changing email address:

  • Must have a FKYC account
  • Should have transacted at least once in the last 6 months
  • Should not have an investment account with Jupiter (We will soon be picking this up as well. Shall keep everyone updated.)
  • You can’t update to an email ID that is linked to an existing Jupiter account.

Note:
You can update your Email ID only once in 90 days.

2 Likes

I am getting below error. I don’t have investment account in Jupiter.

Sure. Let me get this checked. Dm’ed you

@Madhu This was a bug. It shouldn’t have happened :lady_beetle: :mag:

A fix will be rolled out with the next release. You can change it then.

1 Like