Bank transfer issue

Jupiter V1.5.37, iOS

So I tried sending my first bank transfer, when I ran into this issue.

I save the payee info. Then I proceed to the payment page in the app.

If I try entering the phone number first, the amount field shows this bug and wouldn’t let me proceed.

Here’s the sauce:

The only fix I found was to reopen that page all over again. Add in the amount, and the phone number the last.


Plus, it’s kinda a bummer that I can’t copy paste the phone number onto that screen. Always gotta type it in.

Should I try switching screens as I’m awful at remembering numbers, the field gets wiped and I gotta redo the whole set of numbers all over again.


Hey @nateavi
This is a known issue. We’ll be fixing this in the next release :hammer_and_wrench:

Thanks for letting us know though :slight_smile:

1 Like

Shawn Wick:


Haha! :rofl:

it’s we!

Oh thanks. It’s very annoying :sweat_smile:

1 Like

It’s interesting to see folks behaviour on this particular payments page.
Some users select amount first and then the rest, some select phone number first, etc.

@nateavi @nishesh Any particular reason why’d you always go for filling phone number first or it’s just habit? Since other payment apps require selecting the user/number first, then amount, notes, etc - This is understandable.

No worries, we should allow users fill the details in any order of priority.

We’re able to enter it in any order now.
@nishesh @nateavi How about you guys?


Yep, just checked! I’m able to edit the fields any way I choose.

Appreciate the assist, Darth Pinto!

Woohoo! :cool_doge:

1 Like

Yup, can edit the fields any way I want :tada:

1 Like

Perfect! Thanks for letting us know guys :slight_smile:
We’ve got it fixed thanks to you.

1 Like