Jupiter main Page Loading error!

Is jupiter app working? My app is stuck at loading page after entering Mpin showing taking longer than usual. My internet connection is fine and everything else is working beside jupiter app.


Just checked the app & some team members. It seems fine.
@Deveshu_Pathak Can you try switching networks, clear the cache, and try again?

In times like this, I usually turn on airplane mode and switch it off. The network would reset and get slightly faster.

If anyone else is facing this, please let us know in the thread.

Tried Clearing cache, switching networks , switching on and off airplane mode.
but it is still stuck on the loading page.

Other UPI apps are working fine, its just Jupiter.

Got it, let’s get this checked for you.
Reaching out on DMs for more details! :blob_thanks:

I tried reinstalling jupiter, and now its stuck at verifying your mobile number page

Hello Deveshu,

Thank you for connecting with me on the call today. We are happy to see that the issue has been resolved. Please feel free to reach back to us if you have any further queries. Thank you.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.