Bug/Issue on Buy Gold page and Debit Card page


Please check this image that says, Auto-save in gold. Is there supposed to be a button at the end? OR the user is expected to click some where else on the screen to skip that part and move ahead?

Also, I suppose the timer on this animation is supposed ot be low and visible to normal human eyes? Please check the GIF below.

Is this how Jupiter Debit card is supposed to be visible on the Cards Page?

This was tried on the below device:
Device: Poco M2 PRO
OS: MIUI Global 13.0.2

Jupiter App Version: 2.0.18

Please let me know, if these are the expected behavior or there is some issue with my device.

P.S. It would be great if there is an option to buy Gold/Silver coins on Jupiter too.


Was your phone in landscape mode while opening app.
If yes that could be the reason for this UI scaling issue.

If you see the Image, the phone is not in Landscape mode.

Also, I never use Landscape mode :expressionless:

Update: All is working well, now. Not sure what caused the issue.
I tapped the gold notification and I was getting these issue.

Also, tried it multiple times.
Not sure why it started working now and there was an issue earlier.

Nah you did not understand
Steps to recreate this bug:

  1. Rotate your phone to landscape mode
  2. Open jupiter app
  3. After loading rotate your phone back to portrait mode.
  4. Then all the UI elements would be plus sized.

Reopening the app after clearing it from recents will solve the issue

Yeah it might not necessarily be in landscape, a little bit of tilt might have caused it

Yes, and a tilt would make sense if I have Auto-rotate enabled.
I don’t have auto-rotate enabled and Jupiter also doesn’t support landscape(I suppose).

Something else caused the issue.

Here are some pictures

This is so strange :blob_think:
On my phone, the app is set to portrait mode even if landscape mode is selected.

@Abhishek_Ulayil Did you try it on an iPhone?
I tried dong the above steps on a 13 mini, it was fine.

Yeah, check for the rotation lock on iPhone, turn it off and then it should rotate.

This is weird.

Why would it happen on my phone when auto-rotate is disabled.
And that too on specific pages.

This happens when freshly launching app after clearing it from recent apps screen. Otherwise reloading the app from memory works fine.