Tap and pay not working

After just 2 months , my debit cards tap and pay is not working anymore, i tried turning on and off but nothing seems to be working, but i can use swipe pay. I contacted customer support and there is no reply yet…im really disappointed.

Have you checked the limit of tap and pay :thinking:

1 Like

Hey @Abhijith666, while you check the limit, the team would like to check what went wrong.
I’d like to know a few details from you. Let’s connect on DMs :slight_smile:

Yes, its not because of that. Ive tried turning it on and off but still not working.

I am not talking about turning it on and off. There is a slider to determine the limit, see if the limit is not 0.
What was the cost of purchase you were doing?

Hai @Abhijith666 ,
Kindly verify the limit as recommended by Aswin. If there are no issues with the limit and the purchase amount, I recommend attempting the transaction at a different machine, for example, another shop or petrol pump. :+1:

1 Like

Its not zero, i was trying to pay the petrol amount of 100, and ive tried it in other machines too.

1 Like

Tried in several machines, same result. The limit is not the problem.

Then please send an email to support@jupiter.money They will get this issue fixed. Might be an issue with the card of from jupiter’s side

1 Like

I have faced this as well, tap and pay isn’t working on my card since few months even after I tried turning it on and off multiple times in app and changing limits, didn’t had a chance to put a complaint as I was busy so I just ended up turning it off and switching to my other card.


Hello @Navharsh_Kr

If turning it on and off is not working then please try to use it on different POS machines.
If issue persists then email your concern to support team support@jupiter.money.